#1 02-21-2012 1:19 am

jnethery
Helper
From: Orlando, Florida
Registered: 08-02-2007
Posts: 135
Karmojo: 18

Malcolm Rig: Mac abxpicker Issue

Hi, I just download the Malcom rig and I'm trying to figure out how to get the darn picker to work on my Mac. I'm using Maya 2012. I follow all the instructions and when I open up the picker after importing it, all I get is something similar to this:

http://animschoolforums.com/download/file.php?id=25&mode=view

Just a blank image, no controls at all.

Anyone else have the same problem? I've searched and searched the Animschool forum and no solution has surfaced.

This looks like an amazing rig so any help would be appreciated!!

Last edited by jnethery (02-21-2012 1:19 am)

Offline

 

#2 02-21-2012 5:19 am

coolbird22
Model Citizen
From: Mumbai, India
Registered: 02-02-2011
Posts: 520
Karmojo: 50
Moderator

Re: Malcolm Rig: Mac abxpicker Issue

You can try creating a custom abxPicker by yourself, by selecting each controller and creating a button for each. I know it is a long shot and a painful process, but it will help if you really really want to animate with this rig. That's what  I do for each rig I want to animate.

Offline

 

#3 03-01-2012 9:06 pm

btoonz
Registered: 07-18-2011
Posts: 2

Re: Malcolm Rig: Mac abxpicker Issue

Hey guys---I'm having this same issue---running Osx Lion with Maya 2012---get the silhouette  of Malcolm in the picker but no controls---anybody figure this out yet?---thanks!---b

Offline

 

#4 03-02-2012 1:51 am

btoonz
Registered: 07-18-2011
Posts: 2

Re: Malcolm Rig: Mac abxpicker Issue

Ok guys---minus the background image I got the picker to load in Maya 2012 running on OSX Lion----no idea what I did but I'll list what steps I took:

-Because the "library folder" is hidden by default in OSX Lion, I followed the following steps:

"So the new way of viewing ~/Library is to hold the Option key and choose Go > Library in the Finder. You can even press Option after you drop the Go menu.  Once you can see the ~/Library folder, you can drag its icon (or its proxy icon from a Finder window’s title bar) to either the toolbar or sidebar of a Finder window. Once there, accessing it is merely a matter of clicking the icon."  ----read the full directions here:  http://tidbits.com/article/12306

-Since I have both Maya 2011 & 2012 loaded on my machine I decided to see if I could Malcolm into the 2011 version since 2012 wasn't working.
-I followed the instructions on animschool's website for loading the rig files.
-2011 then opened the picker (minus the picker's bg) and the controls all worked after I adjusted the name in the outliner (like it says to do under the official instructions)
-Everything worked!
SOOOOOOOO........
-I decided to try to load it in 2012 again using the 2011 assets----followed all of the instructions----and BINGO!  It loaded just like it did in the 2011 version.

So....either the "unhiding" of the library folder had something to do with it or the loading of the files into Maya 2011 before I loaded into 2012 did----still wish the picker's bg would load but the tools seem to be responding---I hope this helps somebody fighting with the same issue---please let me know if you have any success!---thanks!---B

Offline

 

#5 03-27-2012 6:02 pm

attrice
Helper
Registered: 02-03-2009
Posts: 4
Karmojo: 15

Re: Malcolm Rig: Mac abxpicker Issue

I am on Maya 2012, OSX 10.6.8, and I was able to get the picker working without the background.  For me, the main point of confusion was that the instructions on the Animschool website seem to say that you should still place the background image file in your project's 'images' folder before opening the script.  But if you do, the script slaps the Malcolm image on top and voila, non-functioning picker.  So put that file someplace else. 

If you're afraid that you'll lose that background image for when they do update the script for Macs, you can also use a photo editor like Photoshop to convert the MalcolmPicker.bmp to a .png file.  Then you can put MalcolmPicker.png into that images file, it won't mess with the script, and you'll have it in the right place for later on.

Offline

 

#6 06-04-2013 12:38 am

hayleym
Registered: 06-06-2011
Posts: 1

Re: Malcolm Rig: Mac abxpicker Issue

Hi, I'm also running Maya 2012, OSX 10.6.8. I'd almost giving up using the Malcolm rig, but somehow have got it to work with the background.
I followed the instructions on the Animschool website for the mac, but it never seemed to work, so i tried a few things. Their instructions are a little confusing, so i will type the steps i did.

1. Open Maya with a fresh scene then create a new project (File > Project Window, call it something like Malcolm_Test for now then Accept)
2. Reference in Malcolm.ma (v100Maya2009)
3* Import the MalcolmPicker.ma (2009 version not 2011 version)
4. Open the Outliner and rename the Main_PIKR to malcolm:Main_PIKR
5. Open the Reference Editor and select Malcolm.ma from the lower area in the Reference Editor then File > Import Objects From Reference.
6. Copy & paste the abxPicker.mel file into the scripts folder this location /Users/yourname/Library/Preferences/Autodesk/maya/2012-x64/scripts (i ran a search and found the file was also in this folder /Users/Shared/Autodesk/maya/2012/scripts, so maybe put it here too)
7* Paste abxPicker; into the the MEL command line

NOTE: when it works, I get an alert saying "// Warning: Pixmap file not found, using default."

* Do not use the 2011 version of abxPicker.mel and only run abxPicker; not source "abxPicker.mel"; abxPicker;

Not sure why it works, but have managed to get it to work a few times from scratch. It would be great if someone else tried it out to see if it works for them too.

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson